Benton
(Administrator)
Administrator
*

Registration Date: 05-11-2015
Date of Birth: Not Specified
Local Time: 07-22-2017 at 10:54 PM
Status: Offline

Benton's Forum Info
Joined: 05-11-2015
Last Visit: 1 hour ago
Total Posts: 5,438 (6.77 posts per day | 1.38 percent of total posts)
(Find All Posts)
Total Threads: 36 (0.04 threads per day | 0.32 percent of total threads)
(Find All Threads)
Time Spent Online: 1 Month, 3 Weeks, 2 Days, 12 Hours, 17 Minutes, 27 Seconds
Reputation: 18821 [Details]
Comments 6 (1 sent | 5 received)
Additional Info About Benton
Team: Bengals


Buddy List (Total 11)
Benton has made 11 friends, 8 of whom are displayed on this page.

jason

BengalsRocker

wildcats forever

Bryan

Bengalzona

BmorePat87

SteelCitySouth

rfaulk34

Last Visitors
Rotobeast (07-19-2017 - 09:39 PM), Shake n Blake (06-25-2017 - 01:27 PM), wildcats forever (06-08-2017 - 10:39 PM), Matt_Crimson (06-06-2017 - 11:41 AM), TheLeonardLeap (05-31-2017 - 03:13 PM), jason (05-26-2017 - 09:32 AM), BengalHawk62 (05-10-2017 - 03:00 PM), Synric (05-05-2017 - 02:00 PM), TSwigZ (05-01-2017 - 07:44 PM), Wyche'sWarrior (05-01-2017 - 01:02 PM)

Benton's Contact Details
Email: Send Benton an email.
  
Benton' awards.
This user has no awards at this time.

Comments (Total 5)
Marlon23 (01-10-2017 - 03:06 PM)
My threads are awesome, I need some REPPITY POINTS!!! Thanks!
GreenDragon (07-06-2016 - 01:45 PM)
Why have I been banned from the PNR section?
SteelCitySouth (05-03-2016 - 06:59 PM)
What thread? Which one got deleted?
GA9 (10-25-2015 - 12:48 AM)
What you're not going to allow me in the PNR Section?
What are you afraid of Benton, little ole GA9 ?Are you afraid I'll crush the moronic belief system of those on here who think they are intelligent?
First off I doubt you'll answer me and if you do it's going to be some excuse that doesn't hold water.
And by the way I did read the CoC ...I've never have seen anything so hilarious in my adult life ..you do know what adult means correct?
XenoMorph (09-29-2015 - 06:12 PM)
it could just be my browser but today when i hit quick edit it just says loading i have to do the full edit option to get my post to actually show up... Just calling this out in case its not just me.